EDBloggen

Alexander Karlstad. Blogger hovedsakelig om Linux og sånt.

Arkiv for stikkordet «tegnsett»

UTF-8 i MySQL 5.X

ingen kommentarer

Skrevet av Alexander Karlstad

7. oktober 2012 klokken 12.15

Oppgradering til Lucid Lynx

ingen kommentarer

Som vanlig går ikke en oppgradering mellom Ubuntu-versjonene som smurt for mitt vedkommende, men heldigvis blir det færre og færre problemer for hver gang. Her kan jeg presentere en liten liste over tingene jeg hittil har støtt på!

Æ, ø og å i programmer kjørt via Wine

Wine sluttet å støtte Æ, Ø og Å. Siden det ikke bare gjaldt Spotify falt konklusjonen raskt på det faktum at det var et tegnsettproblem.

På en annen maskin jeg hadde installert Lucid på, var ikke dette tilfellet, dermed startet jeg enkelt med å analysere forskjellene i de forskjellige dotfilene, og til slutt fant jeg ut at LANG-variabelen på maskinen med problemene var «nb_NO.utf8», mens på den som fungerte var den satt til «nb_NO.UTF-8».

Jeg er dog litt usikker på hvordan det ordnet seg, men jeg merget mye av standard-bashrc-en til Ubuntu med den jeg hadde fra før (uten at jeg hadde satt LANG der tidligere), samt bekreftet at /etc/default/locale var satt korrekt.

Panelene henger og er skurrete etter innlogging

Av og til er ikonene og indikatorene i toppanelet i GNOME skurrete, forvridde, malplasserte eller borte etter innlogging. En enkel «killall gnome-panel && gnome-panel &» ordner for øvrig dette, men det er unødvendig å kjøre hver gang etter innlogging. En bug opprettet i desember i fjor kan passe inn under beskrivelsen min, men det har vært heller laber aktivitet rundt denne siden i februar.

Skrevet av Alexander Karlstad

10. mai 2010 klokken 02.56

Ruterpassord, brukken autentisering og Twitter-klient

ingen kommentarer

Ruterpassord

Her forleden skulle jeg endre passordet på en D-Link DIR-635-ruter her jeg bor. Jeg tenkte jeg skulle være spenstig og bruke spesialtegn i passordet og gikk for eurotegnet (€). Etter å ha lagret og logget ut av administrasjonsgrensesnittet, prøvde jeg å logge inn med det nye passordet. Til all forbauselse fungerte det ikke.

Jeg fikk litt panikk, tenkte masse gale tanker og ble irritert, spesielt siden ruteren står i en annen leilighet her vi bor så jeg hadde ikke mulighet til å tilbakestille den. I frustrasjon, twitret jeg om "uhellet", og til overraskelse fikk jeg også svar. Tegnsettproblemer.

Jeg prøvde enkelt å skrive passordet i en tekstfil og bruke «iconv» på den fra UTF-8 til latin1, men det fungerte ei. Omvendt, derimot. Deretter kopierte jeg den tilsynelatende brukne teksten inn i passordfeltet og logget inn, og voila! 😀 Dog må det sies at å lagre dataene som UTF-8, men sende de i latin1 uten å konvertere kanskje er litt... dumt, D-Link!

iconv -f latin1 -t utf8 fil-med-eurotegn-i

Brukken autentisering i Ubuntu

En sen kveld der jeg prøvde å få fingeravtrykkleseren på laptopen til å fungere skikkelig i Ubuntu, klarte jeg å ødelegge /etc/pam.d/common-auth-filen, mildt sagt. All autentisering brakk, og bruk av «sudo» ga meg kun

Sorry, try again.
Sorry, try again.
Sorry, try again.
sudo: 3 incorrect password attempts

En stund var jeg redd for å slå av PC-en, så jeg søkte hjelp på IRC. Ikke var det bare en løsning heller:

  1. Starte maskinen på nytt og velge "Recovery mode" i oppstarteren, deretter fikse common-auth, eventuelt kjøre «pam-auth-update»
  2. Starte maskinen på nytt, redigere oppstartskommandoen og legge til "init=/bin/bash" i kjernekommandoen, deretter montere filsystemet på nytt («mount -o remount,rw /») og redigere filen, eventuelt kjøre «pam-auth-update»
  3. Starte opp en Live-CD, montere partisjonen og fikse filen, eventuelt bare kopiere standardfilen fra Live-CD-en.

Twitter-klient

gwibberJeg liker veldig godt å eksperimentere og prøve ut ny programvare, og i det siste har jeg prøvd å finne en grei lokalklient for blant annet Twitter, og per i dag står jeg fast på Gwibber. Litt vesentlig å bemerke at det her ikke er den stabile utgaven, men den "ustabilte" 2.0-utgaven (jeg har ikke hatt noe problemer med den). Det eneste jeg synes var kjedelig, var at den kun lastet inn de siste 20 tweetsene, og det blir fort litt i minste laget når man følger over 100 personger og går til sengs. Mye kan skje på åtte timer.

Jeg var beredt på å sende inn et funksjonalitetsønske, men før den tid fant jeg ut at løsningen var enklere:

  1. Start «gconf-editor»
  2. Naviger deg frem til /apps/gwibber/accounts/foo, der "foo" er ID-en til kontoen din.
  3. Legg til en ny heltallsnøkkel kalt "receive_count" og skriv inn hvor mange innlegg som skal lastes 🙂
  4. Oppdater (CTRL+R)

Svaret fant jeg imidlertid her, og det viser seg å være en gconf-setting de ikke har implementert i grensesnittet enda.

Skrevet av Alexander Karlstad

28. september 2009 klokken 01.21

Optimization WordPress Plugins & Solutions by W3 EDGE